题目

原题链接

大家应该都会玩“锤子剪刀布”的游戏:两人同时给出手势。 现给出两人的交锋记录,请统计双方的胜、平、负次数,并且给出双方分别出什么手势的胜算最大。

输入格式:
输入第1行给出正整数N(<=10^5^),即双方交锋的次数。随后N行,每行给出一次交锋的信息,即甲、乙双方同时给出的的手势。C代表“锤子”、J代表“剪刀”、B代表“布”,第1个字母代表甲方,第2个代表乙方,中间有1个空格。

输出格式:
输出第1、2行分别给出甲、乙的胜、平、负次数,数字间以1个空格分隔。第3行给出两个字母,分别代表甲、乙获胜次数最多的手势,中间有1个空格。如果解不唯一,则输出按字母序最小的解。

输入样例:
10
C J
J B
C B
B B
B C
C C
C B
J B
B C
J J

输出样例:
5 3 2
2 3 5
B B

解析

将出的手势转换成数字,然后就可以用if来判断各种情况了

代码

C++解法

#include <iostream>
using namespace std;

int getLevel(char a) {
    if (a == 'C')
        return 2;
    if (a == 'J')
        return 1;
    if (a == 'B')
        return 0;
    return -1;
}

int judge(char a, char b) {
    int aLevel = getLevel(a);
    int bLevel = getLevel(b);
    if (aLevel == bLevel)
        return 0;
    else if (aLevel - bLevel == 1 || aLevel - bLevel == -2)
        return 1;
    else
        return -1;
}

int score[2][3] = {{0, 0, 0}, {0, 0, 0}};
int cnt[2][3] = {{0, 0, 0}, {0, 0, 0}};

int main() {
    cin.tie(0);
    cin.sync_with_stdio(false);

    int n;
    cin >> n;
    for (int i = 0; i < n; ++i) {
        char a, b;
        cin >> a >> b;
        int nowScore = judge(a, b);
        ++score[0][1 - nowScore];
        ++score[1][1 + nowScore];
        if (nowScore == 1)
            ++cnt[0][getLevel(a)];
        if (nowScore == -1)
            ++cnt[1][getLevel(b)];
    }

    // cout << cnt[0][0] << " " << cnt[0][1] << " " << cnt[0][2] << endl;
    // cout << cnt[1][0] << " " << cnt[1][1] << " " << cnt[1][2] << endl;

    int maxValue = 0;
    for (int i = 0; i < 3; ++i)
        maxValue = maxValue > cnt[0][i] ? maxValue : cnt[0][i];
    char aMax = maxValue == cnt[0][0] ? 'B' : maxValue == cnt[0][2] ? 'C' : 'J';

    maxValue = 0;
    for (int i = 0; i < 3; ++i)
        maxValue = maxValue > cnt[1][i] ? maxValue : cnt[1][i];
    char bMax = maxValue == cnt[1][0] ? 'B' : maxValue == cnt[1][2] ? 'C' : 'J';

    cout << score[0][0] << " " << score[0][1] << " " << score[0][2] << endl;
    cout << score[1][0] << " " << score[1][1] << " " << score[1][2] << endl;
    cout << aMax << " " << bMax << endl;

    return 0;
}