题目

Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7

题解

>最长上升子序列<
需要记录每一个老鼠的原始序号

然后按照重量排下序,套用最长上升子序列即可
最后要输出任意一组序列
用一个 last 数组记录每个位置的上一个字符的位置即可

读入坑了十几发……
真的不能乱用 ++
然而 VS 的逐步调试显示竟然没问题……

代码

/*
By:OhYee
Github:OhYee
HomePage:http://www.oyohyee.com
Email:oyohyee@oyohyee.com

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;

const int maxn = 1005;

struct Node {
    int n;
    int speed;
    int weight;
    bool operator > (const Node& rhs)const {
        return (speed > rhs.speed) && (weight < rhs.weight);
    }
    bool operator < (const Node& rhs)const {
        if(weight == rhs.weight)
            return speed > rhs.speed;
        return weight < rhs.weight;
    }
};

Node mice[maxn];
int dp[maxn];
int last[maxn];
stack<int> s;

void Do() {
    while(!s.empty())
        s.pop();
    memset(dp,0,sizeof(dp));

    int n = 1;
    while(scanf("%d%d",&mice[n].weight,&mice[n].speed) != EOF) {
        mice[n].n = n;
        n++;
    }
    n--;

    sort(mice + 1,mice + n + 1);

    int Maxpos = 1;
    for(int i = 1;i <= n;i++) {
        for(int j = 0;j < i;j++)
            if(mice[j] > mice[i] || j == 0)
                if(dp[j] + 1 > dp[i]) {
                    dp[i] = dp[j] + 1;
                    last[i] = j;
                }
        if(dp[Maxpos] < dp[i])
            Maxpos = i;
    }

    printf("%d\n",dp[Maxpos]);

    int k = Maxpos;
    while(k) {
        s.push(k);
        k = last[k];
    }
    while(!s.empty()) {
        int t = s.top();
        printf("%d\n",mice[t].n);
        s.pop();
    }

}

int main() {
    Do();
    return 0;
}