题目

Time Limit: 1000 ms Case Time Limit: 1000 ms Memory Limit: 64 MB
Total Submission: 41 Submission Accepted: 26

Description

一个名为PC的安大学生希望写一个程序来计算三角形的三条边长,你可以帮帮她吗?

Input

第一行是一个整数m(0<m<200),代表有m组数据。
之后m行,每行有三个整数(x<10000),三角形的三条边

Output

如果可以构成三角形,输出三边之和,否则输出"Wrong"

Sample Input

2
3 4 5
3 4 9

Sample Output

12
Wrong

Hint

采用结构:
……
scanf("%d",&ncase);
for(……)
{
scanf(……);
……
printf(……);
}

题解

使用三角形两边之和大于第三边、两边之差(的绝对值)小于第三边判断三角形是否成立

代码

/*
By:OhYee
Github:OhYee
Email:oyohyee@oyohyee.com
*/
#include <cstdio>
using namespace std;
 
int main() {
    int m,a,b,c;
    scanf("%d",&m);
    while(m--) {
        scanf("%d%d%d",&a,&b,&c);
        if(a + b > c && abs(a - b) < c) {
            printf("%d\n",a + b + c);
        } else {
            printf("Wrong\n");
        }
    }
    return 0;
}