HDU 5984.Pocky

题目

题面

Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure.
We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts.
Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above.
Round it to 6 decimal places behind the decimal point.

输入解释

The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

输出解释

For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

样例输入

6  
1.0 1.0  
2.0 1.0  
4.0 1.0  
8.0 1.0  
16.0 1.0  
7.00 3.00  

样例输出

0.000000  
1.693147  
2.386294  
3.079442  
3.772589  
1.847298  

题解

题意相对比较容易理解
对于一根长度为 L 的木棍,每次等概率的取一个点将其分成两半,然后吃掉左边一半,直到剩下的长度小于 d,计算需要吃(分割)次数的数学期望

显然,如果 L/d 相同,则结果必定相同
根据 ln2 = 0.693147 可以推测出结果应该是 ln(L/d) + 1
再单独考虑不需要分割的情况( d>=L )

证明

定义 f(x) 为长度为 x 时,的数学期望
如图,对于 f(x)x<=d 这时已经满足条件,有 f(x)=0
而对于 x>d 其结果应该是从上面任选一点后求其右半部份的数学期望再加上本次分割的 1

φ\varphi 表示从长度为 x 的线段上取到一个点的概率,有 0xφdt=1\int_{0}^{x} \varphi dt = 1
也即 φ=1x\varphi=\frac{1}{x}

也即

f(x)={0,xd1+0dφf(t)dt+dxφf(t)dt,x>d={0,xd1+0df(t)dtx+dxf(t)dtx,x>d={0,xd1+dxf(t)dtx,x>d\begin{aligned} f(x) &= \begin{cases} 0 && ,x\leq d\\ 1+ \int_{0}^{d} \varphi f(t)dt + \int_{d}^{x}\varphi f(t)dt && ,x > d \end{cases} \\ &= \begin{cases} 0 && ,x\leq d\\ 1+ \frac{\int_{0}^{d} f(t)dt}{x} + \frac{\int_{d}^{x} f(t)dt}{x} && ,x > d \end{cases} \\ &= \begin{cases} 0 && ,x\leq d\\ 1+ \frac{\int_{d}^{x} f(t)dt}{x} && ,x > d \end{cases} \end{aligned}

其中,特别要注意的是
limx>df(x)=0\lim_{x->d_-} f(x) = 0

limx>d+f(x)=1\lim_{x->d_+} f(x) = 1

因此可以得知 f(x) 不是一个连续函数
但是我们迭代运算的部分都是 x > d 部分

f(x)=1+dxf(t)dtx=1+F(x)F(d)x\begin{aligned} \because f(x) &= 1 + \frac{\int_{d}^{x}f(t)dt}{x} \\ &= 1 + \frac{F(x) - F(d)}{x} \end{aligned}

f(x)=xF(x)F(x)+F(d)x2=xf(x)dxf(t)dtx2=xf(x)x(f(x)1)x2=1x\begin{aligned} \therefore f{}'(x) &= \frac{xF{}'(x) - F(x) + F(d)}{x^2} \\ &= \frac{xf(x) - \int_{d}^{x}f(t)dt}{x^2} \\ &= \frac{xf(x) - x(f(x)-1)}{x^2} \\ &= \frac{1}{x} \end{aligned}

f(x)=ln(x)+Climx>d+f(x)=1f(d)=ln(d)+C=1C=1ln(d)f(x)=ln(x)+1ln(d)f(x)=ln(xd)+1\begin{aligned} \therefore & f(x)=ln(x)+C \\ \because & \lim_{x->d_+} f(x) = 1 \\ \therefore & f(d) = ln(d) + C = 1 \\ \therefore & C = 1 - ln(d) \\ \therefore & f(x) = ln(x) + 1 - ln(d) \\ \therefore & f(x) = ln(\frac{x}{d}) + 1 \end{aligned}

综上所述
f(x)={0,xdln(xd)+1,x>d\begin{aligned} f(x) = \begin{cases} 0 && ,x\leq d\\ ln(\frac{x}{d})+1 && ,x > d \end{cases} \end{aligned}

代码

/*//
#define debug
#include <ctime>
//*/
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <iomanip>
using namespace std;

int main() {
    #ifdef debug
    freopen("in.txt", "r", stdin);
    int START = clock();
    #endif
    cin.tie(0);
    cin.sync_with_stdio(false);

    int T;
    cin >> T;
    while (T--) {
        double a, b;
        cin >> a >> b;
        if (a <= b)
            cout << "0.000000" << endl;
        else
            cout << fixed << setprecision(6) << 1.0 + log(a / b) << endl;
    }

    #ifdef debug
    printf("Time:%.3fs.\n", double(clock() - START) / CLOCKS_PER_SEC);
    #endif
    return 0;
}